Fuses! - VADriven.com Forums

Tech Talk Anything technically related to your vehicle should be posted here. If you're looking to have work done, try one of the Regional Forums.


Fuses!

Reply

 
 
 
Old 06-30-2017, 11:06 AM
  #1  
Black girls love me!
Thread Starter
 
91tegrsjg's Avatar
 
Join Date: Jul 2007
Location: virginia beach
Posts: 1,253
Default Fuses!

SO......

I have been running into little electrical gremlins on my 07 Street Bob (harley for you none bike types). I replaced my regulator (bad), checked the stator (Ok), battery test (ok), and the grounds (ok). Ever since then, I have been getting an intermitent battery light and check engine (low battery voltage). I had enough and started riding around with a voltage reader, when it came on, I would check the battery, no problems well within normals

Yesterday I replaced all the fuses, a 40 amp main and the 15 amp accessory fuses. All of the fuses had a white build up and a carbon build up on them, but none were blown. Can this be the issue, and what could be causing this?
91tegrsjg is offline  
Reply With Quote
Old 07-01-2017, 03:52 AM
  #2  
-RepLegion
 
Rosco The Iroc's Avatar
 
Join Date: Dec 2002
Location: NE PA
Posts: 909
Default Re: Fuses!

With how sensitive new cars and I'm sure bikes also are now I could see how the little bit of resistance that crud would make could mess it up. Just take them out and put them back in. You will scrape it off in the process.

Reset fuses, C 127
Rosco The Iroc is offline  
Reply With Quote
Old 07-01-2017, 10:08 AM
  #3  
±RepLegion
 
92_SR20's Avatar
 
Join Date: Jan 2006
Location: Virginia Beach, VA
Posts: 2,527
Default Re: Fuses!

https://www.hdforums.com/forum/

Pretty active and useful Harley forum, maybe someone else has had similar issues :dunno:
92_SR20 is offline  
Reply With Quote
Old 07-04-2017, 05:50 AM
  #4  
Black girls love me!
Thread Starter
 
91tegrsjg's Avatar
 
Join Date: Jul 2007
Location: virginia beach
Posts: 1,253
Default Re: Fuses!

I've tried the harley forum, many of hours in the garage searching that. Lots of people had carbon on their fuses, but they were all blown. None of mine were blown.

I bought a toothbrush and electronics cleaner. Pretty gross.
91tegrsjg is offline  
Reply With Quote
Old 07-07-2017, 12:59 AM
  #5  
LickMyButthole
 
yeldak99's Avatar
 
Join Date: Sep 2007
Posts: 2,543
Default Re: Fuses!

Not being a smart ass, but have you made sure the battery connections are tight? I had a similar issue with my Victory and it was a loose cable.
yeldak99 is offline  
Reply With Quote
Old 07-10-2017, 06:20 AM
  #6  
Black girls love me!
Thread Starter
 
91tegrsjg's Avatar
 
Join Date: Jul 2007
Location: virginia beach
Posts: 1,253
Default Re: Fuses!

Oh no, I totally understand. Harley tech told me the same thing. I did check them, both tight. I after checking everything, I'm positive it was those fuses. I haven't had the issue since changing them.
91tegrsjg is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SinceNine19
Tech Talk
12
03-23-2004 06:57 PM
hondazccivic
Tech Talk
4
12-18-2003 07:12 AM
THATS FRESH
Tech Talk
10
10-16-2003 06:53 AM
NIC668
Tech Talk
4
05-26-2003 09:01 AM
rowe4166
Tech Talk
4
03-20-2003 01:44 PM


Quick Reply: Fuses!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: