Notices
Tech Talk Anything technically related to your vehicle should be posted here. If you're looking to have work done, try one of the Regional Forums.


1995 Chevrolet 4.3L Stalls

Old 10-26-2015, 09:45 AM
  #1  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default 1995 Chevrolet 4.3L Stalls

So a good friend of my mom has been having some problems with her van and I volunteered to help. It's a standard distributor Chevrolet 4.3 V6. The spider injector had sprung a leak, so I replaced it along with the return lines, and plenum gasket. All was well until a few days later the van started stumbling at idle and eventually chocked dumping a bunch of fuel on the ground.

The engine hydrolocked with fuel in most cylinders - another intake plenum gasket and a failed oring at inlet line right at the spider. Changed the oring, cleaned everything out, dumped fuel from the cylinders, new plugs and wires. The van ran like a champ, went for a test drive and all is well. Next day started it up and it is stumbling at idle - checked the fuel pressure and it's holding at 52PSI, cleaned the IAC, cleaned the EGR, checked all connections and vacuum lines, still crappy idle with eventual stalling.

Replaced the IAC, cleaned the EGR again, replaced the TPS, rechecked plugs, checked FPR with bleed down, sprayed carb cleaner all over thinking there is a vacuum leak I somehow missed. Still stumbling after 30 secs or so and eventually stalls. No engine codes, does not feel like an electric miss, the fuel pressure goes up as the IAC attempts to compensate but still stalling.

I am a bit stumped - what am I missing ?
euthorus is offline  
Old 10-27-2015, 08:32 AM
  #2  
Registered Member
 
Join Date: Jul 2004
Location: Charlottesville
Posts: 774
cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24
Default Re: 1995 Chevrolet 4.3L Stalls

Is 52 psi with the vacuum line hooked up to the regulator or not? I am not sure what the pressure is supposed to be on that vehicle, but if that reading is with the vac line hooked up I know that is a high reading compared to stuff I have worked on before. Once the vehicle shuts off have you pulled a plug to see if it is soaked in fuel?
cardana24 is offline  
Old 10-27-2015, 09:28 AM
  #3  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 1995 Chevrolet 4.3L Stalls

Originally Posted by cardana24 View Post
Is 52 psi with the vacuum line hooked up to the regulator or not? I am not sure what the pressure is supposed to be on that vehicle, but if that reading is with the vac line hooked up I know that is a high reading compared to stuff I have worked on before. Once the vehicle shuts off have you pulled a plug to see if it is soaked in fuel?
52-60ish psi is its happy range. Leaving the gage on and letting it sit for 10mins still hold 50psi. I am starting to wonder if my map sensor is toast or I have a major compression loss or perhaps somehow the timing is off. But mostly think its MAP since I restored 2-3 broken vacuum lines and it's pulling a lot more vacuum now than it had in years.
euthorus is offline  
Old 10-27-2015, 10:56 AM
  #4  
Registered Member
 
Join Date: Jul 2004
Location: Charlottesville
Posts: 774
cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24 cardana24
Default Re: 1995 Chevrolet 4.3L Stalls

Yeah, I looked around a little more after I replied to the thread earlier because I am not that familiar with throttle body injection. What about the coolant temp sensor, that would have some bearing over the amount of fuel being delivered. Are the plug soaked once it dies?
cardana24 is offline  
Old 11-06-2015, 04:34 PM
  #5  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 1995 Chevrolet 4.3L Stalls

not a real sensor - just a reference plug. Found my MAP wires and connector are messed up as well as thewires going into the spider...joy
euthorus is offline  
Old 11-18-2015, 10:40 AM
  #6  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 1995 Chevrolet 4.3L Stalls

Well, finally gave up and took it to a shop. It's been there one week now and they dont know whats wrong with it :/
euthorus is offline  
Old 11-24-2015, 11:26 PM
  #7  
Registered member
 
Join Date: Apr 2009
Posts: 325
type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup type-r coup
Default Re: 1995 Chevrolet 4.3L Stalls

There is a module in the dizzy that goes bad a lot. I'm sure its been check/replaced
type-r coup is offline  
Old 12-01-2015, 05:15 AM
  #8  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 1995 Chevrolet 4.3L Stalls

Need to take a second look, now it runs fine until it warms up then stalls, start up fine and immediately stall
euthorus is offline  
Old 12-03-2015, 04:48 PM
  #9  
RIP DRAGVA-2016
 
Join Date: Sep 2008
Location: super secret
Posts: 17,404
NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch NasTHatch
Default Re: 1995 Chevrolet 4.3L Stalls

any news on this yet ?
NasTHatch is offline  
Old 12-03-2015, 04:58 PM
  #10  
Standartenführer
Thread Starter
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 1995 Chevrolet 4.3L Stalls

All of the plugs are firing like they are supposed to, the ICM under the dizzy is not a suspect in my opinion as I am not getting any trouble starting at all. The searching idle seriously feels like fuel or air but I can't find a fault with either. I am at a loss with this cursed thing.
euthorus is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Slooby
Domestic
10
04-30-2012 06:36 AM
LegionRacer757
Domestic
0
09-28-2011 05:59 PM
Misfit
Domestic
15
12-27-2009 03:45 AM
TheRealGrizeg
Domestic
1
08-02-2008 08:53 AM


Quick Reply: 1995 Chevrolet 4.3L Stalls


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: