Notices
Tech Talk Anything technically related to your vehicle should be posted here. If you're looking to have work done, try one of the Regional Forums.


RSX TYPE S PROBLEMS

Old 11-15-2013, 03:20 PM
  #1  
Registered Member
Thread Starter
 
Join Date: Oct 2013
Posts: 51
rsxisformen has disabled reputation
Default RSX TYPE S PROBLEMS

First issue : my brake lights stop working and the only thing that cross my mind was a brake light switch so I replaced it and they were working for a little awhile but now they don't anymore , any ideas ?


Second Issue: when I start my car come up I've noticed I idle at 1900 and stay there for a few Mintues I'm thinking a vacuum leak , Any ideas ?

Also if you know the problem please tell me the steps .
rsxisformen is offline  
Old 11-15-2013, 04:40 PM
  #2  
SHAKESHAKESHAKESHAKE
 
Trunk Impaired's Avatar
 
Join Date: Apr 2010
Location: Western
Posts: 4,087
Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired Trunk Impaired
Default Re: RSX TYPE S PROBLEMS

Between this and the thread you made 3 days ago, sounds like your car is beat man. You say you're running lean, possibly have a fuel leak, no brake lights, and having idle issues. Might be time to just bite the bullet on this one and see a professional. Seriously, with all the money you'll spend diagnosing these problems (without actually seeing the car no one here can give you airtight advice and you don't know if these problems could be interconnected or signs of something much more serious) you might as well find out everything that's going on.
Trunk Impaired is offline  
Old 11-15-2013, 05:09 PM
  #3  
Registered Member
Thread Starter
 
Join Date: Oct 2013
Posts: 51
rsxisformen has disabled reputation
Default

Well im not running lean anymore I think I need a new iacv I'm going to clean and see how it acts and I think my wiring has a short in it just a matter of finding it now lol
rsxisformen is offline  
Old 11-15-2013, 10:30 PM
  #4  
Registered Member
 
Join Date: Nov 2009
Location: Chesapeake
Posts: 17
Euphonic has disabled reputation
Default Re: RSX TYPE S PROBLEMS

Originally Posted by rsxisformen View Post
First issue : my brake lights stop working and the only thing that cross my mind was a brake light switch so I replaced it and they were working for a little awhile but now they don't anymore , any ideas ?


Second Issue: when I start my car come up I've noticed I idle at 1900 and stay there for a few Mintues I'm thinking a vacuum leak , Any ideas ?

Also if you know the problem please tell me the steps .

A lot of cars idle high during a cold start... to warm the engine up.
Euphonic is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: