Go Back  VADriven.com Forums > Automotive Forums > Tech Talk
05 Chevy Trailblazer won't start after head gasket replacement >

05 Chevy Trailblazer won't start after head gasket replacement

Notices
Tech Talk Anything technically related to your vehicle should be posted here. If you're looking to have work done, try one of the Regional Forums.


05 Chevy Trailblazer won't start after head gasket replacement

Old 08-27-2013, 07:27 PM
  #1  
The VW guy
Thread Starter
 
AirSick's Avatar
 
Join Date: Sep 2010
Location: Hell hole
Posts: 1,151
AirSick AirSick AirSick AirSick AirSick AirSick AirSick AirSick AirSick AirSick AirSick
Default 05 Chevy Trailblazer won't start after head gasket replacement

Ok Fabrik8, I have one for you because I am stumped on this. I recently purchased a 05 trailblazer with 97k on it with a 4.2 I6. It drove fine for the first week or two then started over heating. My first thought was the thermostat so that was replaced. About 2 days later it started overheating again, so i checked out the electric clutch fan. All is well. A budy of mine did a leak down test and come to find out the head gasket was blown near the last two cylinders.

Well my buddy and I proceed to pull the top end apart to replace the head gasket. We made sure to mark every wire connection, every hose and every bolt to make sure all went back where it came from. Before we disassembled the timing chain and sprockets we marked everywhere we could to be sure the timing was where it should be.

All goes well (with the exception of 5 head bolts breaking and getting the head shaved from some warping) when being put back together. Timing marks line up, hand rotate the engine to make sure they stayed, all connections and hoses go back where they came from. Go to crank it up and nothing. All it does is turn over.

Had it towed to my buddys shop so he could put it on the can machine. Two codes popped up, P2101 (Throttle actuator position performance) and P060E (Control module tp system performance). This is a drive by wire system to boot. It seem like it needs a new throttle body but that shouldn't keep it from running. He pulled a spark plug to check for a fuel odor and there was no odor. Checked for fuel pressure at the fuel rail and it was within specs. Checked all wiring and all is good. At this point we don't know what to do besides take it to a dealer which I was wanting to avoid.

Any help would be greatly appreciated.
AirSick is offline  
Old 08-28-2013, 05:00 AM
  #2  
Racetracks
 
Fabrik8's Avatar
 
Join Date: Nov 2002
Location: How long is a piece of string?
Posts: 15,671
Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8
Default Re: 05 Chevy Trailblazer won't start after head gasket replacement

From a purely analytic standpoint, I'd say the throttle body and control module are fine, and likely something got damaged with the wiring during removal or reinstall, or you have a main ground that is damaged/disconnected/incomplete from when things were reinstalled. If they worked before you pulled the head, and you haven't bashed the throttle body on anything, there is no reason that it should not function now unless something external is the actual problem (like the wiring, etc).

If the throttle body is damaged (or the ECU thinks it is) it can cause a no-start condition because there is no backup system for engine airflow. Most drive-by-wire throttles have dual throttle position sensors for redundant safety, and often dual wiring for TPS 5V power/ground, so if the problem is in the wiring than it is most likely something that would affect both sensors at the same time.

I know that's the same conclusion you've already thought about, but it's the one that makes the most sense from a long-distance view.

How have you tested the wiring, and have you tested TPS signal power/ground at the TPS connector?

So the ECU isn't allowing the starter to engage at all, or is it just not transitioning from crank to run?

Last edited by Fabrik8; 08-28-2013 at 05:08 AM.
Fabrik8 is offline  
Old 08-28-2013, 05:14 AM
  #3  
Racetracks
 
Fabrik8's Avatar
 
Join Date: Nov 2002
Location: How long is a piece of string?
Posts: 15,671
Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8 Fabrik8
Default Re: 05 Chevy Trailblazer won't start after head gasket replacement

I guess I should give my standard disclaimer that I can only help with the troubleshooting process and don't know anything about the specifics of a Trailblazer. I stay far away from domestic SUVs, or really any truck product from most manufacturers for that matter.
Fabrik8 is offline  
Old 09-01-2013, 03:45 AM
  #4  
Standartenführer
 
euthorus's Avatar
 
Join Date: Aug 2007
Location: VA Beach
Posts: 894
euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus euthorus
Default Re: 05 Chevy Trailblazer won't start after head gasket replacement

check these 3 connectors and go crazy with WD40 "from the window to the wall style"

euthorus is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
grgazn
Tech Talk
7
12-17-2009 01:56 PM
1aznTT
Tech Talk
16
10-11-2009 07:37 AM
LIL-BUSA
Domestic
1
12-25-2008 09:49 AM
Hexalot²
Tech Talk
7
05-23-2006 09:38 AM
VAhslr
Tech Talk
5
06-04-2004 06:25 AM


Quick Reply: 05 Chevy Trailblazer won't start after head gasket replacement


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: